Can't Play!

If you found a bug in Illarion or need help ask here. / Wenn Du einen Fehler in Illarion gefunden hast oder Hilfe benötigst, frage hier.

Moderators: Community Managers, Developers

Posts: 631
Joined: Wed Jan 28, 2009 9:58 pm

Post by PurpleMonkeys » Tue Jan 10, 2012 1:02 am

Can't Play!

Hello there, I just went to log in today and I can't play. Now, before I paste the error log, I want to mention that I updated my Java to 7, the newest version I think. Would this cause a problem in playing? Thanks.

Posts: 2429
Joined: Sun Aug 03, 2003 6:15 pm

Post by Athian » Tue Jan 10, 2012 1:04 am

Re: Can't Play!

its quite possible that is the cause of the problem. Try rolling back your Java to the previous version and seeing if it will work then.

Developer
Posts: 12208
Joined: Wed Nov 10, 2004 9:14 pm
Location: Sir Postalot

Post by Estralis Seborian » Tue Jan 10, 2012 10:05 am

Re: Can't Play!

Well, Java 6 Update 30 is the latest stable version of Java, so Java 7 might be buggy; note that the current client was developed for Java 5, so it is quite likely that Java 7 caused your problem if you changed nothing else about your system.

Nevertheless, this is a good opportunity to support the developers ;-) by posting the error log and also, checking out whether the new client plus the development tools work with Java 7. So, if you can spare a minute, check out this link:

http://illarion.org/~nitram/downloads/i ... nload.jnlp

With the new client, you can log in to the testserver;

Account: testserver
Password: testserver

The map editor won't work, but you can check out the easyNPC and easyQuest editor as well.

Any error that might occur can, if you agree, be forwarded to the Mantis bugtracker automatically!

Posts: 631
Joined: Wed Jan 28, 2009 9:58 pm

Post by PurpleMonkeys » Wed Jan 11, 2012 5:48 am

Re: Can't Play!

Alright, I clicked that download link you provided, and I again got an error upon Java 7 trying to load it. And as for the error logs, you want them in Mantis, or here, or does it matter? And do I post the Lanch File, the Exception, or both?

And I think I'll just drop down to Java 5.. :( Seems I have to choose Illarion over Minecraft(which requires Java7).

Community Manager
Posts: 4168
Joined: Tue Sep 19, 2006 6:03 am
Location: A field of dandelions

Post by Achae Eanstray » Wed Jan 11, 2012 6:14 am

Re: Can't Play!

Have you tried deleting Illarion in your java console then re-downloading it? Worth a try if haven't.

Posts: 631
Joined: Wed Jan 28, 2009 9:58 pm

Post by PurpleMonkeys » Wed Jan 11, 2012 6:25 am

Re: Can't Play!

I doubt there's anything wrong with my Illarion files as they are. I even had slight issues while running Illarion on Java 6, and after some thought I'm fairly sure Java 7 is the cause of the further issues.

Posts: 631
Joined: Wed Jan 28, 2009 9:58 pm

Post by PurpleMonkeys » Wed Jan 11, 2012 6:43 am

Re: Can't Play!

I thank you for your help, but I've resolved the issue. I simply right clicked my desktop icon for Illarion, and 'Open With', where both Java 6 and 7 were listed. Though I'd still be happy to give the error logs for 7 if you want them.

Developer
Posts: 12208
Joined: Wed Nov 10, 2004 9:14 pm
Location: Sir Postalot

Post by Estralis Seborian » Wed Jan 11, 2012 9:25 am

Re: Can't Play!

Yes, any error log will help!

Is this perhaps from you? http://illarion.org/mantis/view.php?id=6847

Btw: Do not roll back to Java 5. Just use the latest stable build of Java 6, update 30 that is. Java 5 is simply... outdated.

Developer
Posts: 1999
Joined: Sun Aug 15, 2004 7:10 pm
Illarion e.V.: Chairman

Post by Vilarion » Wed Jan 11, 2012 10:46 am

Re: Can't Play!

Java 7 will not be supported for the current client. It is not even released as stable yet.

Return to “Support and Bugs / Hilfe und Fehlermeldungen”

cron
Powered by phpBB® Forum Software © phpBB Limited
Designed by ST Software.